Forum Logo Welcome, Guest. Please login or register.
Did you miss your activation email?
November 19, 2017, 15:06:33 | See new unread posts
Home Help Search Arcade Chat Login Register

nifflas.ni2.se  |  Nifflas' Support Forum  |  Being Creative  |  Nifflas' Sources  |  Topic: egomassive's Knytt Stories Plus mod « previous next »
Pages: 1 ... 59 60 61 62 [63] 64 65 Print
Author Topic: egomassive's Knytt Stories Plus mod  (Read 199960 times)
egomassive


Total My honestly gotten stars: 227
Offline Offline



View Profile WWW
« Reply #930 on: June 11, 2017, 08:22:57 »

So, opening the file gets me this, while trying to extract gets me this. Opening in 7zip I get this, and then extracting that gives me this. Doesn't matter where the zip is located. What does it want from me??
It didn't upload properly. The file size is supposed to be 871 KB. It should work now.


Edit: Been digging through what is being asked of those dll's. Aside from a very remote possibility of a memory handling flaw, they don't look to be the culprits. Unfortunately, the reason I immediately looked in their direction is because this glitch looks like it comes from a compatibility issue between the core of the engine (which I have no access to) and your machine/OS. However, I've looked through the Level Editor's source, and I've discovered something. When you "reload" the map editor portion of the program closes and re-opens, but the script editor only reloads the information it's displaying. If you hide and then show the script editor it will fully close and re-open.

The point is, try toggling the visibility of the script panel. I'm betting that will set it straight.

« Last Edit: June 11, 2017, 10:08:36 by egomassive » Logged
SilasMann


Total My honestly gotten stars: 30
Offline Offline


A Real Horse


View Profile
« Reply #931 on: June 13, 2017, 00:57:33 »

Interesting stuff! I haven't had the glitch happen to me since, but I did have something else happen randomly: all of the buttons on the script panel disappeared. I closed and re-opened the panel, which fixed it, but did a thing to the editor map. Of course it's a benign bug, and if it's a problem specific to me, I guess it's no problem to restart the editor occasionally.
« Last Edit: June 13, 2017, 00:59:07 by SilasMann » Logged
egomassive


Total My honestly gotten stars: 227
Offline Offline



View Profile WWW
« Reply #932 on: June 13, 2017, 10:58:06 »

Of course it's a benign bug, and if it's a problem specific to me, I guess it's no problem to restart the editor occasionally.
This may be a sign of things to come. Right now it's just you that I know of, but if you have a new machine then this problem may affect everyone in the future. Also, the fact that graphics which should be destroyed are instead moving leads me to think you have a major memory leak, maybe we all do. I might be able to fix this by destroying the problem elements before closing parts of the program. I'll let you know.
Logged
Purple Ink


Total My honestly gotten stars: 27
Offline Offline



View Profile
« Reply #933 on: July 01, 2017, 08:38:10 »

Well, I've tried everything and can't seem to get it to work. I might be out of luck but I'll ask anyway. Is it possible to use two different sign fonts in one game? I want to have characters talking and distinguish them by two different font colours.
Logged
egomassive


Total My honestly gotten stars: 227
Offline Offline



View Profile WWW
« Reply #934 on: July 03, 2017, 02:59:54 »

@ Purple Ink: Sergio came up with a solution for this for the level Juni's Nightmare. Make a font image where the uncommon letters and symbols at the bottom are replaced with your alternative color alphabet. Then use the widget at this link to easily convert to the alternate alphabet.
Logged
Purple Ink


Total My honestly gotten stars: 27
Offline Offline



View Profile
« Reply #935 on: July 07, 2017, 23:49:22 »

Wow that's actually a really elegant solution! Thanks for the tip. :)
Logged
Vegetal Gibber


Total My honestly gotten stars: 113
Offline Offline


Sorry excuse for a game designer


View Profile WWW
« Reply #936 on: July 28, 2017, 13:03:18 »

I've tried making a simple OCO for bouncer #12 (the tiny red/brown guy) for a small project I'm currently working on, but I think I've run into an animation issue very similar than the one StraightFlame reported recently. I'm using the KSDS template for said object as a base, which seems to meet the requirements mentioned in the KS+ instructions. However, it seems both the "small jump" animation (frames 15-18)  and the "blinking" animation (frames 0-2) end at the wrong frame (frame 2 -- eyes closed), even when using KS+ 1.3.0:



I've also attached the PNG strip that causes the problem, just in case there's something else I'm missing.

yel 
* yel  
Logged

Some KS levels by me:
StraightFlame


Total My honestly gotten stars: 60
Offline Offline


Super Duper High School Palette-Swapper


View Profile
« Reply #937 on: July 28, 2017, 20:50:36 »

When i made my Bank10Obj12 OCO, i just swapped the blinking animation frames around so frame 2 is the one where its eyes are open.

I'm not 100% sure, but i think that's actually how it's supposed to work.
Logged

           


Mystery project status:
Currently working on finishing the first area.
Vegetal Gibber


Total My honestly gotten stars: 113
Offline Offline


Sorry excuse for a game designer


View Profile WWW
« Reply #938 on: July 28, 2017, 21:13:07 »

Hmmm... I didn't try swapping the frames because I thought that would mess up the "big jump" animation, but it seems that's not the case. Maybe it'd be a better idea to just make a note of this in the instructions TXT file then, instead of altering the current behavior (so existing OCOs don't have to be modified).
Logged

Some KS levels by me:
egomassive


Total My honestly gotten stars: 227
Offline Offline



View Profile WWW
« Reply #939 on: July 30, 2017, 02:56:15 »

@VG: I compared your sprite sheet to the KS source, and everything is correct except for the order of the first three frames. The correct sequence for blinking is partially-closed, closed, open. I think this is true for every blinking object. If you look at the existing KS+ templates this is how they are laid out. The majority of animations in the game hold on the last frame of each sequence. Apparently KSDS doesn't always sequence the same way, so testing and comparing to existing KS+ templates would be wise.
« Last Edit: July 30, 2017, 02:59:22 by egomassive » Logged
Vegetal Gibber


Total My honestly gotten stars: 113
Offline Offline


Sorry excuse for a game designer


View Profile WWW
« Reply #940 on: July 30, 2017, 13:58:41 »

Interesting. It's quite strange that only the "blinking" frames are swapped around in KSDS... I wonder what's the reason behind this. In any case, it seems to be working fine after using the workaround suggested by StraightFlame, so I'll just keep this in mind for any other OCO I may decide to make. Thanks guys!
Logged

Some KS levels by me:
GrayFace


Total My honestly gotten stars: 54
Offline Offline



View Profile WWW
« Reply #941 on: August 06, 2017, 14:08:59 »

"Use Alternate Death" bugs:
1) After winning (or probably pressing F2) and starting/loading a level again, standard death animation is used despite the menu item staying checked.
2) The state of the menu item isn't saved after exiting KS+, so each time it has to be turned on manually.
Saving its state after clicking the menu item would probably solve both problems.

I now also experience that bug, in KS Ex and original KS save points re-trigger rapidly while Down arrow is pressed. I'd like to carry the fix over to KS Ex. Must be a lot of objects affected. (MMF2 never stops surprising with how horrible it is)

P.S. It's been such a long time since I last played KS.
« Last Edit: August 06, 2017, 14:49:32 by GrayFace » Logged

egomassive


Total My honestly gotten stars: 227
Offline Offline



View Profile WWW
« Reply #942 on: August 06, 2017, 22:44:12 »

@GrayFace: Been a long time since your gray face has appeared around here. I haven't looked yet, but I think I made the alt-death save to the save slot of the level. Staying checked when it's turned itself off certainly needs to be looked into. I imagine fixing that will reduce the need to turn it on so often.

I'm glad to hear the rapid saving wasn't something I did. All I did to fix it was delay how often a save can be initiated. I believe I also changed some of the graphics due to a Win8 incompatibility with certain methods of working with alpha channels which doesn't occur with Win10. Here's the source.
« Last Edit: August 06, 2017, 22:45:47 by egomassive » Logged
GrayFace


Total My honestly gotten stars: 54
Offline Offline



View Profile WWW
« Reply #943 on: August 07, 2017, 17:37:54 »

I'm glad to hear the rapid saving wasn't something I did. All I did to fix it was delay how often a save can be initiated. I believe I also changed some of the graphics due to a Win8 incompatibility with certain methods of working with alpha channels which doesn't occur with Win10. Here's the source.
Great, it's just the "Fade Out=Fade" that doesn't work, so you've replaced that with frames of it fading out. Some unimportant "Childs" still have it set to Fade BTW. I'll handle them.
Strange thing is that I didn't experience it on Win 7 at first, but now I do.
« Last Edit: August 07, 2017, 17:55:36 by GrayFace » Logged

Vegetal Gibber


Total My honestly gotten stars: 113
Offline Offline


Sorry excuse for a game designer


View Profile WWW
« Reply #944 on: August 10, 2017, 13:52:41 »

I was experimenting with the crumbling block (Bank 15 Obj 38) and noticed something weird when I placed a Delete trigger on top of it (not on the same position, but one tile above). If the trigger is activated, the object right above the crumbling block is removed and the block remains on screen, as expected. However, once this happens, the block below the Delete object starts behaving like a regular gray block and won't fall apart when the player steps on it. This happens even if the Overlay feature is not enabled.

Does anyone know of a workaround for this? I tried making an OCO with an X offset of 24, so I can place the object on a different position, but this doesn't displace the collision mask.
Logged

Some KS levels by me:
Pages: 1 ... 59 60 61 62 [63] 64 65 Print 
nifflas.ni2.se  |  Nifflas' Support Forum  |  Being Creative  |  Nifflas' Sources  |  Topic: egomassive's Knytt Stories Plus mod « previous next »
Jump to:  


Login with username, password and session length

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines