Forum Logo Welcome, Guest. Please login or register.
Did you miss your activation email?
May 27, 2017, 22:20:54 | See new unread posts
Home Help Search Arcade Chat Login Register

nifflas.ni2.se  |  Nifflas' Support Forum  |  Released Games  |  Within a Deep Forest  |  Topic: Running the game on modern screens. « previous next »
Pages: [1] Print
Author Topic: Running the game on modern screens.  (Read 961 times)
loner


Total My honestly gotten stars: 0
Offline Offline


View Profile
« on: January 01, 2017, 07:06:14 »

Within a Deep Forest holds a special place in my heart, so I decided to replay it again on a dark winter night, just like I have when I first played it.

Unfortunately now it's more like "Within a Small Box", because on Windows 8.1 with a 1080p monitor the game is absolutely tiny with its 640x480 resolution. Even setting the game to fullscreen results in the game staying in the same tiny box, just with black bars filling up space on all sides. Is there any fix or workaround for this? Or perhaps a way to render the game at 2x or 3x the size?

Would hugely appreciate it if someone can help me find a solution.

Logged
sergiocornaga
Beta Tester


Total My honestly gotten stars: 113
Offline Offline





View Profile WWW
« Reply #1 on: January 01, 2017, 08:35:43 »

When I press F1, it automatically changes the screen resolution to suit. Since yours seemingly doesn't, you could try right clicking the application, choosing properties, choosing the compatibility tab, and checking the box marked 'Run in 640x480 screen resolution'. If that still doesn't work, the issue may be that your monitor or graphics card isn't set up to support 640x480 resolution. Some graphics card software will let you add custom screen resolutions, but that will vary depending on the card you're using, and you can probably find instructions for that with Google (or post a reply asking for more information if it comes to that).
Logged
LPChip
You can only truly help other people by allowing them to fail.
Administrator


Total My honestly gotten stars: 110
Offline Offline


Excel at the thing you're the best at!


View Profile WWW
« Reply #2 on: January 01, 2017, 15:04:11 »

It may also be that your monitor has a setting to show any resolution other than 1080 still in its native resolution and add borders.
Logged

If this post was helpful to you, please consider giving it a shorter hidden star code by pressing the on the left, above my avatar.

MODPlug Central Forum
"If I tried to kill you, I'd end up with a big fat hole through my laptop." - Chironex
loner


Total My honestly gotten stars: 0
Offline Offline


View Profile
« Reply #3 on: January 01, 2017, 18:58:55 »

Thanks for the suggestions, I managed to fix the problem through NVidia Control Panel!

For anyone else with the same problem, here's how I solved it:
In NVidia Control Panel, on the left side there is a section called "Adjust Desktop Size and Position". Inside there should be a setting called "Perform scaling on: ...", which was set to "Display" in my case. After setting it to GPU and running the game in fullscreen it now properly scales to full height.

Now I only wish I could preserve the sharpness of the image. :/ Perhaps there's a setting for that somewhere too...
EDIT: The term I was looking for is "Integer Scaling", and it seems neither NVidia nor AMD support it right now, so I'm out of luck here. 
« Last Edit: January 01, 2017, 20:22:44 by loner » Logged
Pages: [1] Print 
nifflas.ni2.se  |  Nifflas' Support Forum  |  Released Games  |  Within a Deep Forest  |  Topic: Running the game on modern screens. « previous next »
Jump to:  


Login with username, password and session length

Powered by SMF 1.1.20 | SMF © 2013, Simple Machines